Home > How To > No Sound From Tweeter

No Sound From Tweeter

Contents

Loading... Sponsored/Promoted Content Main menu News Latest News Elac Element EA101EQ-G amplifier has room calibration and app control 10 Christmas gift ideas under £50 Noble Audio Sage: an "entry-level" pair of £500 http://forum.analogconsole.com/image..._schematic.jpg Theres a super-complicated schemicatal image of an ns-10 cross over... Somehow get Utopia No.7 into doors and wire up the crossover. his comment is here

Focal Utopia No.7 passive kit in garage awaiting installation with 2x DLS A3 Plans: a little more dynamatting for boot, then all installed properly. If you have a multimeter (DMM) and can disconnect the tweeter you could ohm it out. I would guess duff tweeter. More components in an active crossover to go wrong E46 Build in progress- HU Kenwood KDC-BT61UAmps Genesis Profile Sub, Genesis P4 UltraSub - Type-R 12Speaker - Type-R SPR-17S3 tons of 4mm have a peek here

No Sound From Tweeter

Focal Utopia No.7 passive kit in garage awaiting installation with 2x DLS A3 Plans: a little more dynamatting for boot, then all installed properly. Yes, correct, but will still be outside the 4 - 8 ohm range, depending on the original speaker specs, but the majority of drivers are within this range. Top Log in or register to post comments Tue, 2013-05-14 06:42 #2 Overdose Offline Last seen: 1 year 10 months ago Joined: 08/02/2008 - 18:23 Posts: 3672 RE: Tweeter not working? Sign in to make your opinion count.

I would replace the other tweeter as well, and keep the old working one as a spare. 2 Yamaha NS10M Tweeters Brand NEW FOR NS 10M NS10 Pair Tweeter JA0518A Dealer I tried taking off the tweeter from the front but I couldn't see much that way. Ok I don't have any capacitors lying around but let me get this straight. How To Test If A Tweeter Is Blown Back to top #16 greeef greeef If it ain't broke, fix it 'til it is. Feedback: View 5,109 posts Location:Sheffield Posted 21 Oct 2012 - 16:22 yep, mike is right.

Typical specifications given on manufacturers details are across the speaker terminals and are for total impedence of whatever circuitry is inside the box, not usually for each individual driver, as this Both Tweeters Stopped Working If you have a DMM, and the skills to open the tweeter, you might be able to fix that broken connection. Yes, correct, but will still be outside the 4 - 8 ohm range, depending on the original speaker specs, but the majority of drivers are within this range.

Sometimes working, sometimes not.

The blue V IS conected to the same post that the black tweeter wire is. How To Repair A Tweeter Guess I will be looking into options. Not sure what I will do if I can figure out how to do that. The tweeter's inductor connects at that point as well, and also connects to the Blue wires. (Blue wires are the cabinet's negative inputs) After confirming that everything is connected, take any

Both Tweeters Stopped Working

Leo.. https://www.gearslutz.com/board/so-much-gear-so-little-time/864929-yamaha-ns-10-repair-tweeter-not-blown-just-not-working.html However, since I have spent a bit of money on audio stuff recently, I don't know what I want, I don't really want to get new speakers right now (eventually I No Sound From Tweeter The amp seems to be ok. Car Tweeter Not Working That makes perfect sense.

They're just sitting in storage anyway. this content Moderator, yes you can move thread where it would get more responses, thank you! Google "NS10 crossover", images, and you will see other versions of this backplate. Note that passwords are case-sensitive. How To Test A Tweeter Speaker

Who was poking around and messing around with things they don't understand? 2) Why did you buy a pair of broken NS-10's? saab stock radio - eeeuurgh. c627627 is offline Rules Quote Quick Reply Reply Page 1 of 3 1 2 3 Bookmarks Digg del.icio.us StumbleUpon Google Facebook Furl Reddit MyWeb Yahoo Tags bad , bass http://atomirc.net/how-to/hdmi-sound-to-tv-mac.html Maybe a new thread is in order.

CoolDudeClem 30,382 views 5:15 Loading more suggestions... No Sound From Tweeter Crossover About Press Copyright Creators Advertise Developers +YouTube Terms Privacy Policy & Safety Send feedback Try something new! Shawn flickhtguru is offline Quote post #4 of 7 Old 11-16-2012, 01:37 PM - Thread Starter gonzolt Newbie Join Date: Nov 2012 Posts: 3 Mentioned: 0 Post(s) Tagged:

A second order filter without a (tweeter) load is a dead short to the amp at the L/C resonance frequency.

If sound comes out then you know the drivers are OK, but again, don't turn the volume up much at all or you will blow the tweeter. Shelly, You could try ohming the tweeter out without disconnecting it, and compare it to the good one. Alpine INE-W928R, Alpine PXA-H800 / RUX-C800, DLS A4 (bridged), Focal Utopia 6W3 mids & Utopia Tweeters with 165KR2 Crossovers, JL Audio 6w3s in rear doors (currently redundant), DLS A6, JL 12W7 How To Test Crossovers For Speakers It's easy!

Somehow get Utopia No.7 into doors and wire up the crossover. Also, if a reading is ~ or 0, surely that indicates a problem no matter what the impedance is.. Sign in Transcript Statistics 5,154 views 1 Like this video? check over here Digital Hi-End Projectors - $3,000+ USD MSRP Rear Projection Units OLED Technology and Flat Panels General OLED Technology Great Found Deals!

Super quite, running no sound to the ns 10s, then switched to them on the monitor controller and turned the volume up very slowly and low. It made a world of difference. I'm not sure what a matching tweeter means, but I can send a pic if you would like. Black tweeter return wire connects to the blue wire that goes to the back terminal.

I'm not sure what caused this but this is how it came in to me. Sometimes a tweeter failure will be CAUSED by a crossover failure. And possibly cause a failure there too? As for your sub HA, if it's the UFW-10 the drop in replacement is the Dayton Audio plate amp...

Sign in 2 2 Don't like this video? Good luck, Anthony Yes, please move this thread to the DIY Speakers forum. I had a loose connection which I fixed but this didn't solve the problem.