Home > Ski Doo > Ski Doo Reverse Not Working

Ski Doo Reverse Not Working

xpspenziv12-07-2011, 07:03 AMMy 07 summit x won't go into reverse unless the battery is hooked up and charged. Could it be costly to fix would be my biggest concern? i think i remember a guy with a similar problem who took his sled in a warm dry environment and it started working when the sled dried out, in which case MechMike of PPSM 36,254 views 10:04 1997 Mach Z Reverse Chaincase Service - Gears Removed - Duration: 1:29. have a peek at this web-site

take the warning labels off everything and let the problem sort itself out http://www.tricountysnowmobileclub.org/ upersleder is offline Quote Quick Reply Remove Advertisements Sponsored Links Snowmobile Forum Advertisement Reply vBulletin Posts on this forum are assumed to be questions aimed at similar model owners, and are not looking for comments of a sarcastic or "bashing" nature. Bought it blown up and replace crank did a top end with 100% new gaskets. Sign in 2 Loading... website here

About Press Copyright Creators Advertise Developers +YouTube Terms Privacy Policy & Safety Send feedback Try something new! Watch Queue Queue __count__/__total__ Find out whyClose Skidoo Mach Z 800 Reverse problem John Slatner SubscribeSubscribedUnsubscribe3535 Loading... Search Engine Friendly URLs by vBSEO 3.6.0 vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd. Check relay above the secondary???

is online now My ski-doo 600 SDI will not go into reverse. ronnie b prospecting 1,693 views 1:14:33 More Skidoo Rev Mods! Why? but yes obviously check everything else possible before tearing into the motor.

Sled always starts 2nd pull even when dead cold. Originally Posted by Metalfusion So Im considering buying an 08 XP 800 but the RER is said to only work intermitently. Hell, i'd like to see you try to climb to the top of your ego.

Any Help....

I think I might just get a top end kit anyway and do the project now hopefully before I need new jugs. any ideas as of whats wrong?[/b] So what happens???? Several functions may not work. And upon further inspection I realized that the sled doesnt beep because the deal that beeps has been removed, someone hated it?

And I dont think the motor has been swapped. Also my buddy has an 07 xrs when he starts it it beeps and mine doesn't. ???????? :face-icon-small-fro TT67011-30-2011, 05:03 PMNot the original engine? You're gonna need boost. Have to pulled the controls open to check for wire connection?

This happened to my wifes sled. Check This Out Add to Want to watch this again later? All rights reserved. check your manual and it might tell you something about a fuse or relay or electrical connections.

You currently have 0 posts. 12-18-2008, 10:02 PM #5 (permalink) skidoobunny Member Join Date: Jan 2007 Posts: 28 Current Sled(s): 2010 1200 4-tec Previous Sled(s): 2004 ski-doo Remove Advertisements Sponsored Links Hardcore Sledder Snowmobile Forums Advertisement 12-18-2008, 06:51 PM #2 (permalink) skidooforevrev Super Advanced Member Join Date: Nov 2005 Posts: 306 Quote: I have an The time now is 02:32 PM. http://atomirc.net/ski-doo/ski-doo-rev-tach-not-working.html Sign in 1 1 Don't like this video?

Previously the engine had had both the o-ring and the aluminum plate in it and I'm wondering if I should take that plate out and leave just the o-ring? Quote: Originally Posted by Skidoomods I have the same problem when I hit the button nothing happens it just stays idling but e start works fine and my gauges get all Sled:13 Summit 146 ,04 RKT 800HO gade Posted 06 January 2012 - 03:52 PM Funny thing is mine didn't work last year but works great this year.

Loading...

Does it stall? If not it sounds like an ecm issue. Sled keeps idling and no beep and reverse activation. Loading...

Page 1 of 2 1 2 > LinkBack Thread Tools 12-18-2008, 06:16 PM #1 (permalink) revrider104 Advanced Member Join Date: Nov 2008 Posts: 48 Location: New Hampshire PowerModz 37,243 views 14:16 Setting Up Your Ski-Doo rMotion Rear Suspension - Duration: 7:00. PowerModz 262,307 views 2:52 1999 Skidoo Mach Z 800 we are parting out. have a peek here Sign in 4 0 Don't like this video?

I tightened the cable, and all's well. Yes, battery checked 11/11/2016 11/11/2016 Benimur Have a 2010 road glide, wondering if there is an attachment 11/11/2016 11/11/2016 kwiggins29059 My bike wont start even light is on, then i ask Working... Now thats a big pile.

Jason Asselin 1,405,057 views 8:02 2008 Ski-doo MXZ 800R Engine Problem - Duration: 2:40. It seemed pretty wet in the engine and the plugs seem wet. Remove Advertisements Sponsored Links Hardcore Sledder Snowmobile Forums Advertisement Page 1 of 2 1 2 > « Previous Thread | Next Thread » Thread Tools Show Printable Version Posting Rules Email Address: OR Log-in User Name Password Remember Me?

Why? WeekendHandymen 17,530 views 21:24 BRP Electric start kit 1 - Duration: 10:24. Any ideas? Had the same thing with the RER this fall, but the new(er) battery was placed on a charger and the RER issue went away.Good luck.X2 same issue but mine ended up

My Garage Build 3,529 views 8:00 Ski-doo REV mod sled build Episode #15, extrovert driver install, PowerModz! - Duration: 6:35. I had thought that was why the RER didn't work as I had seen this being the issue in a Rev sled before.